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General Information
How to purchase?
Technical support
How to Register the software?
How to uninstall Dockit 365 Archiver
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How to purchase?

You can purchase Dockit 365 Archiver online from our website http://www.vyapin.com/. Please
contact our Sales department at sales@vyapin.com for sales and price related queries.
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Technical Support

Please send all Technical Support questions to support@vyapin.com.
Please send us the following additional information if you are reporting a problem:
1. Version of Dockit 365 Archiver that you are evaluating or you have registered with us.
(Version information could be found in the "About Dockit 365 Archiver” dialog in “Tools”
tab.
2. Additional services or resource consuming processes/applications (like anti-virus)
running in the background on Dockit SharePoint Manager installed computer.
3. Hardware configuration of the computer where Dockit SharePoint Manager is installed.
4. Archiver_<date&timestamp>.txt" available in the common application data path of Dockit 365
Archiver
(e.g., <Application Data Folder>\Dockit 365 Archiver\Log\Archiver
<date&timestamp>.txt).
5. Dockit 365 Archiver jobs Timestamp folder stored in the application data path. For example:
<Application Data Folder>\Dockit 365 Archiver\JobHistory\<taskname>\<timestamp>.

Note:
<Application Data Folder> is the location where Dockit 365 Archiver jobs and job history is stored in the
computer running Dockit 365 Archiver application. The <Application Data Folder> can be found from
Tools -> About screen. The default path of <Application Data Folder> is as follows:
Windows 10 / Windows 8 / Windows 7 / Windows Server 2012 / Windows Server 2008 C:\Users\Public\Documents
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How to Register the Software?
Once you purchase the software online or through any one of our resellers, you will receive a
purchase notification through e-mail from our sales department. We will send you an e-mail
with the necessary instructions to register the software.

Request License Key
In case you do not receive an e-mail from our sales team after you purchase the software, please
contact our sales department at sales@vyapin.com with the sales order number. You can also request
the license by the filling up the form shown below. Please allow 12 hours from the time of purchase for
our sales department to process your orders.

1. Select About from Tools page.

2. The About Dockit 365 Archiver dialog appears as shown below:
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3. Click Request license Key... button, the Request license Key dialog will appear as shown below:
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Contact Name: End-user of the product.



Company: End-user Company Name.



Email: Email address where the license key has to be sent.



Phone: Phone number with country code and area code.



Order ID: Order/Transaction ID reference.



License Type: License that was purchased.

4. Fill-in the form details and click Submit.

Register software
Perform the following steps to register the software:
1. Download evaluation/trial copy of software from the respective product page available in our
website at http://www.vyapin.com/
2. Install the software on the desired computer.
3. You will receive a license key through e-mail once the purchase process is complete.
4. Click 'Register license Key...' in Tools -> About Dockit 365 Archiver menu to see the dialog as
shown in Image 1 below.
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Image 1 - Register screen
5. Copy the license key sent to you through email and paste it in the 'License Key' textbox. For
help on how to copy the license key, click 'See example' link in the Register dialog (as shown in
Image 2).

Image 2 - How to copy license key screen
6. Once you paste the license key, click Apply button to apply the new license key.
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How to uninstall Dockit 365 Archiver?

When you create SharePoint archive jobs in Dockit 365 Archiver and schedule them, the application
creates Windows Scheduled Tasks (to run the archive jobs at the specified time interval) in the computer
where Dockit 365 Archiver is installed. Archive job results for every task run instance is also maintained
in the computer as application files.
When you uninstall Dockit 365 Archiver through Control Panel - Add / Remove Programs applet,
Windows Installer program will remove only the application files from your machine. But, the application
related files created by Dockit 365 Archiver remain in the computer. In order to remove Dockit 365
Archiver worker files completely, the uninstall wizard provides a set of cleanup options to perform the
cleanup operation based your selection.
Use this wizard to cleanup the files that are created by Dockit 365 Archiver application selectively and
uninstall Dockit 365 Archiver completely from the machine.
1. The Dockit 365 Archiver Uninstall Wizard dialog will be shown as below:

Click Next to proceed.
2. Select required cleanup options as shown below:
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Click Next to proceed.
3. Confirm the cleanup and/or uninstall process.
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Click Finish to run cleanup and/or uninstall process. Click Cancel to close the wizard.
4. Once the file cleanup process is complete, the uninstall wizard will automatically run
Windows Installer program to remove Dockit SharePoint Manager application from the
machine, if you have selected the cleanup option Uninstall Dockit 365 Archiver
application in the wizard.
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Dockit 365 Archiver Job Manager
Job Manager
Edit an Existing Job
Run a Job
Delete an existing Job
Job History
Activity Log
Tools
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Job Manager
1. The Job Manager page will appear as shown below.

2. From this page, you can :
 Create New Archive Job
 Run a Job
 Edit a Job
 Delete a Job
 View Job History
 Server a specific Job.
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Edit an existing job
To edit an existing job:

1. Select a job from the Job Manager page. Click

or click on

icon and select Edit.

2. Dockit 365 Archiver loads SharePoint explorer and File explorer while retaining the configured job
settings.
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Delete an existing job
To delete an existing archive job:
1. In Job Manager Page, Click icon

of the job and select Delete.

Note: Deleting a job will permanently delete the selected job and its history items.
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Job History

When a job is run in Dockit 365 Archiver, the job information is updated in 'JobHistory' folder. The job
history information can be viewed upon clicking

Or Click on

and select Show History.

The history of the job will be displayed as shown below.
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Where
Start Time -> Date and Time a job was initiated.
End Time -> Date and Time a job completed its archive process
Elapsed Time -> Total time (hh:mm:ss) a job has taken to complete its archive process.
Status -> Brief remark about the status of archive.
Total -> Total number of files given for archive in this job.
Total Size -> Total size of files under archive job.
Action -> Deletes the logs and history details of that instance.
Possible Status

Description

Completed

Archive process was completed successfully without any errors

Incomplete

Archive process encountered certain errors

Eval limit reached

Archive process reached the maximum allowed number of files
to import in evaluation / trial version. This message is
applicable for evaluation / trial version only.

Cancelled

Archive process was cancelled by the user.

Failed

The archive process could not be initiated as there were issues.

The following operations can be performed on job history items:

View activity log
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Run a Job

'Start' option of a job in job manager page allows the user to instantiate a job any time after the job
has been created. To run a Dockit 365 Archiver job:
1. In Job Manager Page, Click Start option of the job or click on

icon and select Run Job

2. Office 365 Login Dialog to connect to SharePoint will appear as shown below.
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The given credential will be used to connect to the SharePoint site.

3. The progress of the job will be reported as shown below:
4. It shows the files that are being archived to File share.
Where
Name -> Title of the file.
Source Path -> SharePoint Location of the file.
Size -> Size of the file.
Target Path ->File Share location of the file.
State -> Current State of the file (i.e. In Queue (or) Uploading (or) Completed)
Status:
a.
b.
c.
d.

Files Archived - Shows the total number of files archived to File Share.
Size - Size of files Archived - Total size of files provided for archive.
% - Shows the progress of the job in Percentage(%).
Elapsed Time - Shows the elapsed time from the instance the archive job started or
commenced.
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5. Once the archive job is complete, the information will be updated in Job History section, where
you can view the archive activity performed when the job ran last.
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View Active Log
To view activity log associated with a job history item:

1. Click on Status column value.

2. The Activity Log Viewer page appears as shown below.
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3. The activity log of a job is classified into two different categories :
a. Statistics: Displays a brief summary of the archive process.
b. Status: Displays the task details of the archive process.
Summary View - Displays the summary report of the archive process.
Where
Title -> SharePoint Library/Web Name
Source -> SharePoint location of a file
Target -> File system location of a file.
Activity Date -> Start time of the archive job.
Status -> State of a Library/Web (Archived or Failed).
Remarks -> Brief information about why the Library/Web failed to archive.
Detailed View - Displays the detailed report of the archive process.
Where
Source -> SharePoint location of a file
Target -> File system location of a file.
Size ->Size of the file that is archived.
Activity Date -> Start time of the archive job.
Status -> State of a file (Archived or Failed).
Remarks -> Brief information about why the file failed to archive.
Version History -> Display the File Versions, if available.

4. Additionally, user can open the file share location of activity log by clicking Open log folder
control on top.
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Tools
To know more about Dockit 365 Archiver or register the application, for support click Tools tab on the
Dockit 365 Archiver home screen.
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Create new archive job
Create New Archive Job
Archive Condition
Archive Items
Threshold Settings
Schedule Settings
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SharePoint Object to File Share
To create a new archive job to archive SharePoint Libraries and Subsites along with metadata from
SharePoint to File System:

1. Click Create New Archive Job on Job Manager Page as shown below.

2. Select archive type from Select Type popup as shown below.
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3. The New Job page appears as shown below

27

4. Enter Job Name, Description (Optional)..
5. Specify Office 365 or On-premises site URL in the textbox and click Connect button. You need to
provide a valid site administrator credentials to proceed further.

6. Drag and Drop SharePoint Libraries from SharePoint site (Left Pane) to File share (Right Pane) or
Select SharePoint Objects and Right click SharePoint Explorer, select Archive.
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7. Click Archive Items on Right pane to check the list of SharePoint Objects selected for
archive, also you can remove SharePoint Objects by clicking the Red X.
8. Specify Archive Condition
9. Specify Threshold Settings
10. Specify Schedule Settings
11. Click Save button to create the job, or click < button to navigate to previous page to change any
job settings.

12. After saving the job, it will be listed on the Job Manager page. You can click on
initiate the archive process.

to
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Archive Items
From SharePoint explorer you can either drag or drop SharePoint Objects to File explorer or
simply select SharePoint Objects from SharePoint explorer Right Click and Select Archive to
add SharePoint Objects to Archive Items.
1. The Archive Items appears as shown below:

2. The selected SharePoint Objects added for archive will be displayed in the Archive Items page.
Dockit 365 Archiver processes the top-level SharePoint Objects added for archive in the order in
which it appears in the Archive Items page. The archive process order can be changed by the
navigation buttons available in the right side of the page. You can remove the SharePoint Objects
added for archive by clicking Red X beside the files.
3. Click > button to proceed.
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Archive Condition
To specify the Archive Condition to be applied by Dockit 365 Archiver when archiving SharePoint Objects
to the destination location:

1. The Archiving Conditions appears as shown below:

2. Select any one of the following Archive Conditions as stated below:

a.
b.
c.
d.
e.
f.
g.
h.

Archive Everything - Archives all SharePoint Objects without applying any condition or rule
to filter content.
Files inactive since / older than - Archives SharePoint documents that were last modified
earlier than the given date.
Files modified between - Archives SharePoint documents modified between from and to
date. The To date is an optional value. The documents that were modified in the given date
range alone will be archived along with its respective document versions.
Files created/modified by user - Archives SharePoint documents that were either created
or modified (depending on the user selection) by the given user or set of users.
Keep the following number of major versions - Retains the specified number of major
versions in SharePoint and archives document versions anything above the defined count.
Files more than this size - Archives SharePoint documents that are greater in size than the
given value.
Libraries having more than these many documents - Archives SharePoint libraries that
have documents / files anything above the defined count.
Libraries inactive since / older than - Archives SharePoint Libraries that were last modified
beyond the specified date.
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Libraries modified between - Archives SharePoint Libraries that were modified between from and
to date. The To date is an optional value.

3. Click on > to proceed.

Post Archive Actions

1. Select any one of the following post archive actions given below:
a.
b.

No action to be taken - No action will be taken, once the archive job is complete.
Delete all items in source after archive job is complete - Deletes the SharePoint objects
that are archived. This option will delete all files in the source library permanently and you
won’t be able to retrieve these items from the Recycle Bin.

Make all items in source as read-only after archive job is complete - The SharePoint objects
that are added for archive will be marked as Read-only objects by altering their permissions. Any
sub-scopes that are created underneath SharePoint sites or libraries will be automatically set to
inherit parent permissions. For example, any unique permissions defined for documents and folders
underneath source SharePoint library will be changed to inherited permissions.
Note: This option will be enabled only when Archive everything option is selected in the Archive
Condition settings.

2. Click on Finish or > to proceed.
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Threshold Settings
To set percentage of Network bandwidth that Dockit 365 Archiver can use during archiving and number
of files that can be archived concurrently to improve performance.
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Schedule Settings
1. The Job Schedule Settings step appears as shown below:

2. Select a Schedule type from Schedule drop-down menu.
3. Click Set Password to specify Username and Password to run the task.
4. Click Save, a windows scheduled task will be created.
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Note: The option Run with highest privileges will be available only if you launch the application using
Run as administrator command.

Reference
Troubleshooting
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Troubleshooting
If and when a problem arises, please forward the following files to support@vyapin.com to revert back
to you with a solution.
1. Error log file - e.g., <Application Data Folder> \Dockit 365 Archiver\Log\Dockit_<date&time-

stamp>.txt
2. For issues while running a job, send us the date and time-stamp folder generated within
the job folder name under 'JobHistory' folder. e.g., <Application Data Folder> \Dockit 365

Archiver\JobHistory\<JobName>\<Date&Timestamp>.The date and time-stamp folder
contains:








Activity log file (ActivityLog.csv)
Error log file (Archiver_20160409-134848.txt)
Job settings file (Detail.xml)
Items to Archive (Items to Archive.csv)
Job Execution file (JobExecution.xml)
Migration Statistics file (ArchiveStatistics.xml)
Upload Statistics file (UploadStatistics.xml)

3. The <Application Data Folder> is the common location where Dockit 365 Archiver jobs and job
history will be stored in the computer running Dockit 365 Archiver application. The <Application
Data Folder> can be found from Settings -> About screen. The default path of <Application Data
Folder> is as follows:
Windows 10, Windows 8, Windows 7,Windows Server 2008, Windows Server 2012 C:\Users\Public\Documents.
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